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F
I N T R O D U C T I O N

irst Rush is a native macOS multi-camera recorder for on-set editorial and post-
production workflows. It records SDI or supported capture-card inputs to edit-ready

movie files, keeps scene / shot / take metadata close to the recording controls, and helps
move material into Final Cut Pro, DaVinci Resolve, and similar tools with less manual
renaming.

The screenshots in this manual use mock sources. Real camera feeds will show live video,
timecode, audio, and SDI metadata when the capture hardware and camera signal provide
them.
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C H A P T E R  1

Requirements

Use First Rush on an Apple Silicon Mac with macOS and vendor drivers installed for your capture
hardware.

Supported capture families:

Blackmagic Design DeckLink / UltraStudio devices through the DeckLink SDK.

AJA devices through the AJA NTV2 SDK.

Recommended on-set preparation:

Install the latest Blackmagic Desktop Video or AJA Desktop Software before opening First
Rush.

Confirm the capture device appears in the vendor utility first.

Feed camera video, embedded audio, and timecode into the capture device.

Use stable storage with enough free space for ProRes recording.

Do a short test record before the first take of the day.
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C H A P T E R  2

Install And Launch

1. Download the latest First Rush DMG.

2. Open the DMG and drag First Rush to Applications.

3. Launch First Rush.

4. If macOS asks for permission, allow camera / audio capture access. First Rush uses these
permissions for professional capture-card input, not the built-in Mac camera.

First Rush is an Apple-Notarized build, so the first launch goes through Gatekeeper without
warnings. If macOS still shows an "unidentified developer" alert, the DMG was likely damaged
during download — fetch it again.

License And 7-Day Free Trial

The first launch opens the license sheet. You have two options:

Start 7-day free trial: Use every feature of the release build for 7 days without a license key. A
countdown appears in the menu bar and the license sheet.

Enter license key: Paste the key you received by email after purchase, then activate. Each key
is bound to one Mac; deactivate / reactivate at any time from the license sheet.

When the trial expires, recording is locked and the license sheet reappears. Signal diagnostics,
FCPXML export, and the Activity Log remain available so you can finish post-trial bookkeeping.

To view license info or move a key to another Mac, open FirstRush > License... .

Sparkle Auto-Update

The direct-DMG build uses the Sparkle framework for automatic updates.

Shortly after launch First Rush polls the EdDSA-signed appcast.xml .

When a new build is available, an update sheet appears. Hit Install Update to download,
verify, install, and relaunch in one flow.

For manual checks, use FirstRush > Check for Updates... .

It is safe to ignore the channel on closed sets — the installed build keeps working without
updates.
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If an update fails, the cause is usually disk permissions, a quarantine attribute, or a blocked network.
Try Check for Updates...  once more, otherwise download the DMG manually.
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C H A P T E R  3

Main Window

The main window has five working areas:

Source sidebar: detected cameras and capture inputs.

Viewer grid: live preview, recording state, timecode, audio meters, and source overlays.

Inspector: metadata, SDI diagnostics, preview effects, LUT, destination assignment, and auto-
record controls.

Slate strip: scene / cut / take entry and slate modes.

Gang control bar: record / stop controls for selected or active sources.

Top-right toolbar buttons control layout, VU meters, timecode display, info overlays, the slate strip,
activity logs, and the inspector.

Layout Menu

Use the Layout  menu in the menubar (or the layout button in the top-right toolbar) to change how
viewer tiles are arranged.

Layout menu
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Options:

Auto Layout : grid sizes itself to the number of active sources.

1x1  / 2x2  / 3x3  / 4x4 : fixed grid.

Primary + Right Strip : one large primary viewer with a thumbnail strip on the right.

Primary + Bottom Strip : one large primary viewer with a thumbnail strip on the bottom.

Toggle Fullscreen : maximize the current viewer area.

Auto Layout  is convenient when the source count changes during the day. The Primary +

Strip  layouts are useful when one camera is the main monitor and the others only need a glance.
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C H A P T E R  4

Sources

Open the Cameras  tab in the left sidebar to view capture sources.

Each source row shows:

Hardware backend: Blackmagic or AJA.

Source name.

Signal / running / recording state.

Enable switch.

Turn a source on before recording. If a source shows no signal, check camera output format,
SDI/HDMI cabling, capture-card input routing, and vendor driver status.

Source Settings

Select a source and click the gear button at the bottom of the sidebar, or use the metadata tag
button on a viewer tile.

Source settings
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Important source settings:

Source name: label used in the UI.

Clip metadata: scene, take / shot, reel / tape, reel number, camera make/model, director, DP,
production, notes.

Video settings: input format and pixel format. Auto-detect is recommended unless you need to
force a format.

Audio settings: channel count, bit depth, audio delay, channel mapping, audio source routing,
pre-record buffer.

Timecode source: SDI embedded, Audio LTC, or Mac Clock.

Auto-record trigger: choose the signal that starts/stops automatic recording.

Multi-Source Apply (Cmd-Click)

To configure several cameras to the same value at once, Cmd-Click  multiple sources in the
sidebar. Selected sources show a yellow highlight in their header, and any change made in the
Inspector / Source Settings is applied to every selected source at the same time.

Common scenarios:

Assign the same destination to cameras A / B / C.

Apply the same codec preset / file-name token to four cameras at once.

Set the same camera label prefix (e.g. CAM_ ) for the whole crew.

Switch all cameras to the same auto-record trigger mode in one move.

Multi-apply is destructive — existing per-source values are overwritten with the new value, so clear
the selection before changing a setting that should stay unique to one source.

Cross-Source Audio Routing

Audio Source  defaults to the source's own SDI embedded audio, but it can also pull audio from
another source and write it into this source's recording. Two common on-set examples:

The A camera only has a distant cam mic, while the B camera has the boom mounted — set
A's Audio Source  to B cam , and the boom ends up inside A's clip.

All four cameras should share the same boom channel — Cmd-Click  to select all four and
route them to one source's audio.

Routing takes effect from the next clip. Clips already recording finish out with their original audio
routing.
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Pre-Record Buffer

The Pre-record buffer  keeps the last N seconds of incoming video in memory at all times.
When REC is pressed, those N seconds are baked onto the front of the clip, so "wait, we just had a
great moment" is preserved.

Recommended: 3–5 seconds (low memory / CPU overhead).

Larger values consume more RAM.

Combined with auto-record (REC Flag), the clip starts slightly before the actual REC flag event.



13

C H A P T E R  5

Destinations

Open the Records  tab in the sidebar to configure where recordings go.

Each destination defines:

Save folder.

Codec preset.

File naming format.

Video settings.

Audio track layout.

Timecode / captions.

Optional post-record behavior.

Select a destination and click the gear button to edit it.

Destination settings
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File Name Format

Use the token palette to build filenames. For example:

S  + Scene  + _C  + Shot  + _T  + Take(auto)  + -  + CamLabel

This produces names like:

S15_C02_T01-A.mov

The preview line in Destination Settings shows the next generated filename before recording.

Codec Preset

Choose the destination codec based on workflow:

ProRes 422 Proxy: lightweight editorial proxy.

ProRes 422 / HQ / higher presets: higher-quality editorial or finishing handoff.

H.264 / HEVC / DNxHR options if enabled in the build and destination settings.

For on-set editorial, ProRes 422 Proxy is usually the safest default unless production requires
another codec.
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C H A P T E R  6

Slate Strip

The slate strip at the bottom applies scene / cut / take values across sources.

Available modes:

Film: standard scene / cut / take workflow.

Drama: episode-aware naming.

Reel: camera reel / clip-name oriented workflow.

Test: separate test clip counter.

Custom: custom naming fields.

Use Auto +Take  when you want the take number to advance automatically after each recording
start. Click Apply  when you want to push the current slate values to the selected sources
immediately.
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C H A P T E R  7

Recording

Manual Recording

Use the bottom control bar:

REC : start recording.

STOP : stop recording.

Record All  / Stop All  from the Recording menu control all selected or active sources.

Keyboard shortcuts:

Command-R : Record All.

Command-K : Stop All.

Command-P : Pause All.

Shift-Command-P : Resume All.

Command-M : Insert chapter marker.

Chapter Markers

Press Command-M  during recording to drop a chapter marker at the current timecode.

The marker is applied to every active recording clip simultaneously (gang marker).

When the session is exported as FCPXML, markers travel with the clips and show up as
Chapter Markers in Final Cut Pro and as Markers in DaVinci Resolve.

Markers receive auto-labels ( Marker 01 , Marker 02 …). Rename them after export inside
the editorial app if needed.

Marker events are also recorded in the Activity Log for later auditing.

Drop a marker on every NG take to make trim-out trivial in post.

Auto Recording

Enable auto-recording per source in the Inspector. The source still needs a destination assignment.

First Rush supports two trigger modes:
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REC Flag (SDI/HDMI) : the stable default. Uses DeckLink SDK record-trigger flags or AJA
RP188 record flag data.

HDMI TC Run (Beta) : DeckLink HDMI-oriented fallback. Starts when timecode begins
moving and stops when timecode holds still.

Auto-record trigger settings

For SDI cameras, keep REC Flag (SDI/HDMI)  unless you are deliberately testing another path.

For Sony mirrorless HDMI workflows, use HDMI TC Run (Beta)  only after setting the camera
correctly:

HDMI Time Code Output: On.

REC Control: On.

TC Run: Rec Run.

Do not use HDMI TC Run with Free Run timecode unless you want First Rush to treat continuous
timecode movement as record activity.
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C H A P T E R  8

Metadata And Auto-Fill

First Rush writes clip metadata into recorded files and keeps the same values visible in the
Inspector.

Metadata fields include:

Scene.

Cut / shot.

Take.

Reel / tape.

Reel number.

Clip name.

Camera make/model.

Camera label.

Notes.

The SDI camera info section listens for metadata from VANC / ANC packets and HUD OCR. Where
supported, First Rush can auto-fill values such as reel, clip name, ISO, white balance, shutter, and
lens information.

The diagnostic chips show:

TC : timecode seen.

REC : record flag seen.

ANC : ancillary metadata seen.

Audio : embedded audio state.

OCR : HUD OCR activity.

If auto-fill is not working, check these chips first. They usually tell you whether the issue is missing
timecode, missing ANC packets, missing audio, or OCR not seeing the camera HUD.

HUD OCR In Detail

Cameras that do not embed metadata in ANC packets (especially mirrorless and some cinema
cameras over HDMI) are handled by reading the on-screen HUD directly via OCR. Fields First Rush
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is usually able to recover:

Reel name (ARRI A001, A002 / RED R3D001 patterns).

Clip name (the file name the camera is recording onto its own media).

ISO / EI.

Shutter (speed or angle).

White Balance / Tint.

Lens info (Cooke /i, ARRI LDS — any metadata-aware lens).

How it works:

1. The preview frame's HUD region is sampled once every 1–2 seconds.

2. ROIs are picked from per-vendor HUD layouts (ARRI / RED / Sony / Blackmagic).

3. Apple's Vision framework recognizes the text, then per-camera parsers slot fields into
metadata.

4. Only successful values are written, and only when Auto-fill  is enabled.

Tips for reliable OCR:

The HUD must be visible in the frame. If you turn HUD off on the main monitor for talent's
sake, OCR goes down with it.

Capture cards that inject an arbitrary LUT can drop text contrast and lower the OCR rate.

Downconverters often blur HUD typefaces enough to fail OCR.

The Help menu's Export SDI Diagnostic...  includes OCR attempt / success counts and the
most recent failure samples. Attach it when reporting low recognition rates.
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C H A P T E R  9

Preview Effects And LUT

Preview / recording effects live in the Inspector.

Common preview tools:

Auto crop.

Keep HUD metadata pinned.

Grid.

Letterbox.

Rotation.

Flip H / Flip V.

Center Cross.

Preview LUT.

By default these are preview tools. Enable Apply to recording  only when you intentionally want
supported effects written into the recorded file.

For safety, Metal preview remains an advanced path. If you are on a real set and the current preview
is stable, avoid changing rendering settings mid-shoot.

Aspect Ratios And Safe Frame

A single shoot day often has clips destined for theatrical, OTT, and short-form deliverables, all with
different output ratios. First Rush handles the most common cases:

Letterbox / Pillarbox guides: 2.35:1, 2.39:1, 2:1, 4:3 framing guides drawn over a 16:9 feed.
The guide is preview-only — useful when blocking action.

2.35:1 auto scale-up: When you want to monitor a 1.78:1 / 1.85:1 master inside a
CinemaScope container with one click — scale + guide together.

Auto Safe Frame: Detects which safe-frame standard the camera is using (ARRI Safe 90%,
RED Action Safe, etc.) via metadata or HUD and overlays it. Fall back to a manual toggle if the
camera does not send that info.
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9:16 Portrait Mode (Reels / Shorts)

A dedicated mode for Reels / Shorts / TikTok workflows.

1. Enable 9:16 Portrait Mode  from the Layout menu or the Inspector.

2. A 9:16 crop frame appears over the 16:9 feed.

3. Drag the frame inside the preview to slide the 9:16 window left / right (to follow the subject).

4. Turn on Apply to recording  to bake the 9:16 crop into the recorded file. Leave it off to
keep the original 16:9 untouched while still seeing the guide.

Cycle Portrait Mode  cycles through 16:9 → 9:16 (center) → 9:16 (left) → 9:16 (right) via the
Layout menu shortcut.

3D LUT Preview (.cube)

Apply a 3D LUT so LOG signals are easier to monitor.

1. In the Inspector's Preview LUT  area, click Pick LUT... .

2. Select a .cube  file (Rec.709 conversion, look LUT, or a camera's official LUT).

3. The preview updates immediately. A strength slider blends the LUT.

4. To bake the LUT into the recorded file, enable Apply to recording .

Recommended flow:

Keep the preview LUT'd for monitoring while leaving the recording as LOG ( Apply to

recording  off).

For an on-set editorial proxy that needs a baked LUT, add a second destination and turn
Apply to recording  on just for that destination — you record original LOG proxies and

LUT-baked proxies side by side.

Standard 17 / 33 / 65 cubes are supported.
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C H A P T E R  1 0

External Monitor

The External Monitor  menu sends a fullscreen feed to a second display — set monitor, director
monitor, or an OBS capture — separate from the main window.

Basic flow:

1. Choose External Monitor > Open External Monitor... .

2. Pick the display from the connected list.

3. Choose what to show: a single source fullscreen, or a mirror of the viewer grid.

4. Close with Close External Monitor  or Esc  while the second-display window has
focus.

Options:

Mirror Viewer Grid: draws the main window's grid onto the external monitor as-is — easy
when pushing the feed to a monitoring room.

Single Source Fullscreen: one source at full screen — best for a director monitor.

Letterbox / Safe Frame: whether the external monitor also shows letterbox / safe-frame
guides.

Hide UI Overlays: hide REC borders, timecode overlays, etc. only on the external monitor —
useful for a director monitor that needs a clean image.

External Monitor is monitor-only. It does not create another file. Recording is always handled by the
main destinations.

Performance note: pushing 4K 60p fullscreen to a second display has a small GPU cost, even on
Apple Silicon. With four or more simultaneous recordings, single-source fullscreen on the external is
the safer choice.
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C H A P T E R  1 1

Activity Logs And Diagnostics

Open View > Activity Log .

Activity and logs

The Activity & Logs window shows:

CPU, memory, disk free, and active recording counts.

Recent source and recording events.

Search.

Clear.

Export.

SDI Diagnostic export.

Use Help menu diagnostics when reporting a signal issue:

Help > Copy SDI Diagnostic

Help > Export SDI Diagnostic...

Help > Email SDI Diagnostic...
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The diagnostic export includes app version, signal format, timecode, record flag state, audio
channel information, recent ANC packet summaries, OCR attempt/success counts, and metadata
source state.
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C H A P T E R  1 2

FCPXML Export

After recording clips, use the FCPXML export button in the top bar. First Rush exports an editorial
project structure based on the clips and metadata it recorded.

Before exporting:

Confirm destination folders are correct.

Confirm scene / cut / take metadata.

Confirm camera labels.

Confirm the clips you need have finished recording.
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C H A P T E R  1 3

iPad Viewer

The iPad Viewer feature streams local monitoring previews to authorized iPhone or iPad clients. The
Viewer is for monitoring only. It does not record clips.

Open iPad Viewer > iPad Viewer... .

Companion Viewer panel

Installing the Viewer App

First Rush Viewer is a separate iPhone/iPad app. Install it from the App Store.

Currently in App Store review. Once approved, the app will be available directly from the App
Store. During the review period it may be distributed through a beta channel; detailed instructions
will follow.

Basic Pairing Flow

1. Start the iPad Viewer server on the Mac.
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2. Create or issue a pairing code.

3. Open First Rush Viewer (installed from the App Store) on the iPhone or iPad.

4. Pair on the same local network.

5. Select the sources the viewer should monitor.

Security notes:

The Mac remains the recorder.

Viewer clients are monitoring clients only.

Pairing code requirements and viewer events appear in the Companion Viewer panel.
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C H A P T E R  1 4

Troubleshooting

No Signal

Check:

Camera output format.

Capture-card input routing.

SDI or HDMI cable.

Vendor desktop utility.

Whether the source is enabled in First Rush.

No Audio

Check:

Embedded audio is present on the camera output.

Source audio channel count and bit depth.

Destination audio tracks.

Channel mapping.

Mute and master monitor volume.

Auto Recording Does Not Start

Check:

Auto record is enabled for the source.

The source has at least one destination assigned.

The correct trigger mode is selected.

SDI cameras: REC flag is present.

Sony HDMI cameras: HDMI TC output, REC Control, and Rec Run timecode are enabled.

Activity Log for REC , STBY , cooldown, or diagnostic messages.
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Metadata Does Not Fill In

Check:

TC , ANC , and OCR  diagnostic chips.

Whether the camera actually sends metadata on that output.

Whether a converter, wireless link, or switcher strips ANC metadata.

Whether the HUD is visible enough for OCR.

Whether Auto-fill is enabled.

Recording File Name Is Wrong

Check:

Slate mode.

Scene / cut / take values.

Destination file name tokens.

Camera label.

Auto +Take  state.
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C H A P T E R  1 5

On-Set Checklist

Before the first take:

Capture hardware detected.

All expected sources visible.

Signal, timecode, audio confirmed.

Destination folder set.

Codec preset confirmed.

File name preview checked.

Scene / cut / take set.

Auto-record trigger confirmed if used.

Test record made and opened in the editorial app.

Activity Log clear enough to watch new events.

During shooting:

Watch red recording borders and REC timers.

Watch disk free space.

Confirm Auto +Take behavior.

Keep an eye on TC / REC / ANC / Audio / OCR chips when metadata matters.

After a setup change:

Re-check signal format.

Re-check audio channel mapping.

Re-check auto-record trigger mode.

Do another short test record.



31

C H A P T E R  1 6

Keyboard Shortcuts

Frequently used shortcuts, gathered in one place.

Recording:

Command-R : Record All (start recording on active / selected sources).

Command-K : Stop All.

Command-P : Pause All.

Shift-Command-P : Resume All.

Command-M : Insert chapter marker.

Slate and metadata:

Command-Return : Apply current slate values to the selected source(s).

Command-] : Take + 1.

Command-[ : Take − 1.

Shift-Command-] : Cut + 1.

Shift-Command-[ : Cut − 1.

Selection and multi-apply:

Cmd-Click : select multiple sources in the sidebar (enables multi-apply).

Shift-Click : range-select sources in the sidebar.

Cmd-A  (sidebar focused): select all sources.

View:

Command-1  / Command-2  / Command-3  / Command-4 : Layout 1x1 / 2x2 / 3x3 / 4x4.

Control-Command-F : Toggle fullscreen on the current viewer.

Command-, : Preferences (where available).

Command-Option-S : Toggle Slate strip.

Command-Option-L : Toggle Activity Log.

Command-Option-I : Toggle Inspector.

iPad Viewer / external output:
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Command-Option-E : Toggle External Monitor.

Command-Option-V : Toggle iPad Viewer panel.

License / updates:

FirstRush > Check for Updates... : Manual Sparkle check.

FirstRush > License... : License sheet.

Some shortcuts may differ slightly per build or macOS version. The shortcuts displayed next to the
menu items are the authoritative source.
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C H A P T E R  1 7

Menu Bar Reference

Top-level menu items.

FirstRush

About FirstRush : version / build / builder ( editor han ).

Check for Updates... : manual Sparkle check.

License... : license / 7-day trial sheet.

Preferences... : general settings (where available).

Hide / Quit FirstRush : macOS standard.

File

New Project : start a new working session (with optional Scene / Cut / Take reset).

Open Recent : recent destinations / projects.

Export FCPXML... : export recorded clips and metadata as FCPXML.

Reveal Destinations in Finder : open the active destination folder.

Edit

macOS standard editing menu (Undo / Redo / Copy / Paste / Select All).

Applies inside the Slate input fields.

View

Show / Hide Inspector  ( Command-Option-I ).

Show / Hide Slate Strip  ( Command-Option-S ).

Show / Hide Activity Log  ( Command-Option-L ).

Show / Hide VU Meters .

Show / Hide Timecode Overlay .

Show / Hide Info Overlay .



34

Recording

Record All  / Stop All  / Pause All  / Resume All .

Insert Chapter Marker .

Auto-record Trigger Mode  (default trigger mode for new sources).

Layout

Auto Layout .

1x1  / 2x2  / 3x3  / 4x4 .

Primary + Right Strip  / Primary + Bottom Strip .

Toggle Fullscreen .

Cycle Portrait Mode  (cycles 16:9 ↔ 9:16 positions).

External Monitor

Open External Monitor... .

Close External Monitor .

Mirror Viewer Grid  / Single Source Fullscreen  toggle.

Hide UI Overlays .

iPad Viewer

iPad Viewer... : open the Companion Viewer panel.

Start / Stop Server .

Issue Pairing Code .

Window

macOS standard window menu (Minimize / Zoom / Bring All to Front).

Help

First Rush User Manual : jump to this PDF (Korean / English).

Copy SDI Diagnostic : copy diagnostic info to the clipboard.

Export SDI Diagnostic... : save diagnostic info to a file.

Email SDI Diagnostic... : send diagnostic info by mail (support).
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Open Activity Log .

Menu items and shortcuts may differ slightly per build / environment. The actual on-screen menu is
the source of truth.


